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Composite application tutorial overview

Composite applications are available with IBM Lotus Notes 8 Beta. These composite applications can be
accessed from the local Notes data folder, the IBM Lotus Domino server, or an IBM WebSphere Portal
server. Using new functionality, you can create combine one or multiple Notes applications into composite
applications that boost organization productivity by providing the end user with a single context in which to
complete their business process. Multiple components in the composite application can be wired in a
causal relationship; when the end user performs a behavior in one component, the other wired components
can react and perform a predefined behavior.

IBM Lotus Domino Designer 8 Beta provides new features to help you, the developer, set up causal
relationships for Notes applications used as components. The new Composite Application Assembly feature
allows you to assemble multiple components into a single composite application and to define the wiring of
the components in a 1-to-1 or 1-to-many relationship.

This tutorial describes how to create a local composite application using procedures that make use of new
features in IBM Lotus Notes 8 Beta and IBM Lotus Domino Designer 8 Beta. It provides an end-to-end
scenario for creating and running a simple composite application using Notes applications as components.

When you complete this tutorial, you will have a composite application with inter-component
communication, similar to that shown below.  Whenever you select a row in the upper component, the lower
component will display the documents that have an identical category value in its embedded view.

The upper component is a view in a Notes discussion database. In order for it to participate as a component
in causal relationships with other components in the composite application, you will enhance it so that it
publishes a value from the currently selected document. The lower component is a Notes form that contains
an embedded view. The lower component  has pre-defined behavior where it reacts to the published value
to list, in the embedded view and documents which have a matching value. This is a causal relationship
with the upper component.

  
Tasks to be performed  
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Developing composite applications is a process that involves multiple procedures. This tutorial has
organized the process into the following procedures, which you should perform in the order in which they
are presented.  

Note  This tutorial contains all the steps you'll need to create your first Notes-based composite application.
You can also reference these procedures when creating your own unique composite applications.

 Lesson 1 -- Creating a new discussion database and documents

 Lesson 2 -- Creating a new Notes form with an embedded view

 Lesson 3 -- Creating a WSDL file to support inter-component communication

 Lesson 4 -- Defining Notes view columns that publish properties

 Lesson 5 -- Defining Notes actions that consume properties

 Lesson 6 -- Creating a composite application

 Lesson 7 -- Adding components to the composite application

 Lesson 8 -- Wiring components in the composite application

Before you begin

This tutorial assumes that you are familiar with creating new Notes databases in the Lotus Notes client. It
also assumes that you are comfortable using prior versions of Lotus Domino Designer to modify Notes
views, create simple Notes forms, and use the Programmers pane to input Notes formulas and LotusScript
code. 

In addition to satisfying the system prerequisites for a Lotus Notes 8 Beta install, found in the release notes,
be sure that you or your administrator have installed the following:

 IBM Lotus Notes 8 Beta (Standard edition)

 IBM Lotus Domino Designer 8 Beta

 Composite applications toolkit

As a prerequisite activity, you may also wish to read through the composite applications toolkit
documentation to gain a sense of supported functionality and application intent.

You can find reference information about the composite applications tools and their functionality in the
composite applications toolkit documentation supplied as a PDF file in your toolkit installation. For reference
information about the latest release of Notes and Domino, see the release notes and the Beta
documentation supplied with Lotus Notes 8 Beta.

Note  The term "Lotus Notes 8 Beta (Standard configuration)" refers to the Eclipse-based edition of Lotus
Notes being introduces in version 8. The term will be shortened to Lotus Notes 8 Beta throughout this
document.
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Lesson 1 -- Creating a new discussion database and documents 

Welcome to Lesson 1.

To complete all lessons in this tutorial, you need the Lotus Notes 8 Beta and Lotus Domino Designer 8 Beta
software installed and set up.

Lesson 1 objective  

In this lesson you will use two procedures to accomplish the following tasks:

 Create a new local Notes database based on the discussion template.

 Create documents in your discussion database.

In later lessons of this tutorial, you will enhance this Notes discussion database to be used in a two
component composite application that supplies inter-component communication through property broker
functionality.
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Lesson 1 - New Notes discussion database with documents
This lesson has two procedures that, when completed, produce a new Notes database based on the
discussion template with documents.  In later lessons of this tutorial, you will enhance this Notes discussion
database to be used in a two component composite application that supplies inter-component
communication through property broker functionality.

Procedure 1.1 - Complete the following steps to create the new discussion database

1. If needed, start the Lotus Notes 8 Beta client.

2. Click File > Application > New.

Result: The New Database dialog appears.
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3. Leave the Server field value at 'Local'.

4. Type MyDiscussion in the Title field.

5. Verify that the File Name field contains MyDiscussion.nsf.

6. Select Discussion - Notes & Web (7) in the Template list.

7. Deselect the 'Inherit future design changes' option.  

Note:  Your new database will not inherit changes from the template.  Therefore any design changes you
make in later lessons of this tutorial will not be overwritten.
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8. Click OK to close the New Database dialog and create the new database.

Result: The new database is created and the About this Application page is displayed in your Lotus Notes
8 Beta client.

9. Close the window tab titled About MyDiscussion.

Result: The default view of the newly created Notes application, MyDiscussion.nsf, appears in your Lotus
Notes 8 Beta client as shown in the following screen capture.

You have completed the first procedure in this lesson.
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Next, you will create documents in this new discussion database. These documents must have values in
the Subject and Category fields to successfully complete the later lessons of this tutorial.

Procedure 1.2 - Complete the following steps to create documents in your discussion database

1. Click New Main Topic in the action bar.

Result: The Main Topic form appears, in which you will specify the field values for the Subject and
Category fields in the new document.

2. Type "Subject1" in the Subject field.

3. Type "Category1" in the Category field.

4. Click Save & Close in the action bar.

Result: The document is saved and you are returned to the Notes view.

5. Repeat the previous steps until there are four documents in the database. The documents should
have the following field values:

Subject value Category value

Subject1                Category1

Subject2                Category1

Subject3                Category2

Subject4                Category2

6. Switch to the By Category view to display your four new documents listed by category field value. 
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Congratulations. You have completed Lesson 1. You now have a new Notes discussion database with
documents that have values in the subject and categories fields. You will use this database and the
documents later in this tutorial to demonstrate inter-component communication in a composite application.

Please proceed to Lesson 2.
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Lesson 2 -- Creating a new Notes form with an embedded view  

Welcome to Lesson 2.

In the previous lesson, you created a local Notes database using the discussion template. You also created
documents in that database to be later used to demonstrate inter-component communication in a
composite application via the property broker function.

Lesson 2 objective  

In this lesson, you will enhance your Notes discussion database with a new Notes 8 Beta form that has an
embedded view. This form will later be used as the lower component in the composite application described
in the overview. When used as a component and wired appropriately, this Notes form will have a causal
relationship with the upper component and will list, in its embedded view, documents matching the value
published, in reaction to user activity, by the upper component.

In this lesson you will use one procedure to accomplish the following task:

 Create a new Notes form for use as a component in your two component composite application.
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Lesson 2 procedure  

Complete the following steps to create a new Notes form for use as a component in your two component
composite application.

  1. Open MyDiscussion.nsf in your Lotus Notes 8 Beta client.

  2. Select any row in the displayed view.

  3. Start Domino Designer 8 Beta by clicking View > Design.

Result: Domino Designer 8 Beta opens and displays the list of forms in MyDiscussion.nsf.

  4. In Domino Designer 8 Beta, click Create > Design > Form to create a new form in MyDiscussion.nsf.

  5. At the top of the form, add the static text "Display documents in category".

  6. Click File > Save to save the form. When prompted, name the form "DocByCategoryForm".

  7. To the right of the static text, add a field to the form by clicking Create > Field. Type
"CategorytoDisplay" in the Name field and set the Type field properties to Editable and Text.

  8. Click to the right of your CategorytoDisplay field and press Enter twice to move down the new form.

  9. Add an embedded view to the form by clicking Create > Embedded Element > View. When the
dialog appears, click the By Category view name.

 10. Click on the newly added embedded view to select it and then click Show single category in the
Objects list. Type CategorytoDisplay in the programmers pane. 

Note  This is the field name you added to this Notes form earlier. When there is a value in the
CategorytoDisplay field, the embedded view will list only those documents that have this same value
in their Category field.
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 11. (Optional) Place your cursor to the right of the embedded view then press Enter. Click  Create >
Field to add a text field named SaveOptions to your form as described in the following substeps:  

a.Use the field's properties box to specify that it is a computed field.

b.Select the programmers pane for the SaveOptions field and set the value to "0".

Note: Include the quotation marks around the zero character.

a.Click SaveOptions in the work pane and double-click to open the properties box for the field.

b.On the 6th tab of the properties box, click Hide from Notes.

Note: Adding the SaveOptions field to your form will prevent users from saving new documents
through this form. Lotus Notes 8 Beta will not prompt you to save changes when you close the
composite application after inter-component communication updates the CategorytoDisplay
field.

 12. Click File > Save to save the changes you have made in this new form.

Note  Because you will use the property broker and LotusScript later to populate the
CategoryToDisplay field, you can close this form now.

 13. Preview the form in Lotus Notes 8 Beta by clicking Design > Preview in Notes.

Result: The form appears in your Lotus Notes 8 Beta session.

 14. Type in a string that matches the category value in the documents you created in Lesson 1, such as
"Category 1" or "Category 2".

 15. Click View > Refresh to refresh the form's embedded view.

Result: The embedded view lists documents that contain the category value that matches what you
typed.
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 16. Press the Escape key to close this new document without saving it.

 17. Close Domino Designer 8 Beta.

Congratulations. You have completed Lesson 2. You now have a Notes form with an embedded view that
you will use as one component in a two component composite application. You will enhance this form in a
later lesson to support inter-component communication.

Please proceed to Lesson 3.
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Lesson 3 -- Creating a WSDL file to support inter-component
communication 

Welcome to Lesson 3. 

In the previous lessons, you completed the following procedures:

 Create a local Notes database using the discussion template.

 Create documents in that database.

 Add a new Notes form to the Notes database.

To complete this lesson, you need the Lotus Notes 8 Beta software installed and set up. Lotus Domino
Designer 8 Beta is not needed for this specific lesson, but is needed to complete later lessons.

Concept and background
Composite applications can simply be an assembly of multiple components with on-the-glass aggregation
that keep the application user focused on the business process, eliminating the need for the application
user to switch between applications or switch between open windows.

To derive additional value and further increase organizational productivity, you can have components form
causal relationships with other components through properties and actions. A property broadcasts a value
and an action consumes a value. In order to make sure that both sides are communicating consistently,
both properties and actions need to describe the type of value they broadcast or consume. This ensures
that sensible connections are made when the components are wired together.

For inter-component communication, each component references a WSDL file that lists the properties and
actions available in that component. The design elements of a Notes database may be exposed as multiple
components, but the database typically requires a single WSDL file. When Notes applications are used as
components, you also need to specify the properties and actions in various design elements in the
database that reference the WSDL. Properties, actions, and types are defined in the WSDL file. Types
themselves can be further classified. 

Composite applications bring together many data realms into one application. Two different data realms
might have a type that is best described as "Category". But the definitions of category in one realm might
not make sense in another. For simplicity you want to call each of the types 'Category', but you want to
prevent an application assembler from wiring together. 

To solve this problem, there is the concept of "namespaces."  Namespaces provide unique descriptors that
you can use to group collections of types into. The name use for a type may exist in multiple namespaces,
but they are considered unique by the composite applications editor.

You may be tempted to create a new datatype for each type of data that your component publishes and/or
consumes. However, you should be aware that users will not be able to wire together components unless
their WSDL definitions use exactly the same typenames in the same namespace. For this reason you
should try to use only standard XML schema types such as xsd:string. If you feel that there is a compelling
reason to use a non-standard datatype, you should like to see if it is possible to register you datatype with
an appropriate standards group e.g. if your component was to be used with you company then you should
register your typename a typename register within your company, but if you hope you component will be
used externally you should seek out an industry wide register of typenames.

Lesson 3 objective  

In this lesson you will use create the WSDL file for the example composite application, you will use the
Property Broker Editor that ships with this product.  Use the following procedures to create the WSDL file.  

Note  For more information on the Property Broker Editor, refer to the the topic "Using the Property Broker
Editor feature in Domino Designer" found in this documentation.

When you are finished you will have created the following definitions to be stored in the composite
application WSDL file:

•Properties design element (WSDL file) - stores application definitions for data types, properties,
namespaces, and actions
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•Datatype for your application

•Property to be shared

•Namespace

•Action
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Lesson 3 procedure

Begin creating the new WSDL file
Use the following procedure to begin creating the new Blank Properties WSDL file (Properties design
element) in Domino Designer.

  1. Open Domino Designer.

  2. Open the MyDiscussion application that you wish to create the new WSDL file for.

  3. Click Composite Applications->Properties.

  4. Click the New Properties button.  

  5. Enter "sample.wsdl" for the File name. You should then see "sample" for the newly created
Properties design element (WSDL file).

7. Select the "sample.wsdl" Properties entry and click Open File.  This launches the Property Broker
Editor.  
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Create the datatypes for your example application
The next procedure in creating the WSDL file for your example composite application is to define the data
types that will be produced or consumed by your composite application components.  

Examples of datatypes contained in the example are "AccountID", "PersonName", "Cost Center".  Output
Properties and Incoming Actions must be the same datatypes to be wired together.

Use the following steps to define the data types for your example composite application:

  1. From the Property Broker Editor, click the Types tab.

  2. Click New Type to create the first new data type for the composite application.

  3. In the Type Details section of the screen, type "CategoryDataType" in the Name field.

  4. In the Type Details section of the screen, select "String" from the Type field drop down list.
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  5. In the Target Namespace  section of the screen, type com.ibm.apps.sample  in the Namespace
field. This will be filled later with the Namespace value that you use when creating properties.

  6. Click File-Save to save your changes.

Create the property for your example application
Use the following steps to define the property for your example composite application:

  1. From the Property Broker Editor, click the Properties tab.

  2. Click Add to begin defining the new property.

  3. In the Property Details section of the screen, type "Category Property" in the Name field.

  4. In the Property Details section of the screen, select "CategoryDataType" from the Type field drop
down list.

  5. In the Property Details section of the screen, type "Category Property" in the Title field. This is the
text that you wish to appear in the component wiring tool.

  6. Type "Used  in Tutorial" in the Description field.

  7. Leave "Allow programmatic publishing" checked.

  8. In the Target Namespace  section of the screen, type com.ibm.apps.sample  in the Namespace
field.

  9. Click File-Save to save your changes.
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Create the action for your example application
Use the following steps to define the action for your example composite application:

  1. From the Property Broker Editor, click the Actions tab.

  2. Click Add in the Actions section of the screen to begin defining the new action.

  3. In the Action Details section of the screen, type "Category Action" in the Name field.

  4. In the Action Details section of the screen, type " Category Action " in the Title field.

  5. In the Action Details section of the screen, type "Used  in Tutorial" in the Description field.

  6. Make sure that "Default action if multiple actions match the property" is not checked.
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  7. In the Action Input Parameter section of the screen, select "Category Property" from the Property
list.

  8. In the Action Output Parameter section of the screen, select " Category Property" and click the Add
button.

  9. Click File-Save to save your changes. 

 10. Close the Property Broker Editor.  

The Property Broker Editor generates a WSDL file that lists the properties and actions that you will add to
your Notes components in later tasks. The WSDL file supports inter-component communication in
composite applications.

In Domino Designer you should now see a circled arrow (Refresh) next to your "sample.wsdl" entry.

Click on the Refresh button and choose the ~sample.wsdl file from the dialog.  Your wsdl file is now created
and imported into the MyDiscussion application.

Congratulations. You have generated a WSDL file that lists the properties and actions that you will add to
your Notes components in later lessons. A WSDL file supports inter-component communication in
composite applications.

Please proceed to Lesson 4.
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Lesson 4 -- Defining Notes view columns that publish properties  

Welcome to Lesson 5.

In the previous lessons, you completed the following procedures:

 Create a local Notes database using the discussion template.

 Create documents in that database.

 Add a new Notes form to the Notes database.

 Generate a WSDL file that lists the properties and actions for a Notes component.

 Import the WSDL file into your application that will be used as a Notes component.

In this lesson, you will add a property to a new column of a specific Notes view.  When this view is used in a
composite application, the property will be published when any row in that view is selected; the property
value will be the column value for the selected document.  In later lessons, you will assemble and wire the
composite application and specify which component consumes this property and the action associated with
the consumption.

Note  To complete this tutorial, you need Lotus Notes 8 Beta and Lotus Domino Designer 8 Beta software
installed and set up.

In this lesson you will use one procedure to accomplish the following tasks:

 Add a new column to the All Documents view.

 Set the properties of the new column to publish a property.
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Lesson 4 procedure  

Complete the following steps to add a new column and set the column properties to publish a property.

  1. In Domino Designer 8 Beta, click File > Application > Open and select MyDiscussion.nsf from the
field list.

  2. Click Views in the design pane on the left to display the view list.

  3. Select All Documents from the view Name column and press Enter to open the view in design
mode.

  4. Click Create > Append New Column to add a new column to the right of the existing columns.

  5. Select this newly added column and click the Field option in the programmers pane at the bottom
right.

  6. Select Categories from the list.  

Note  This specifies that this newly added column will display the contents of the categories field for
the listed document.

  7. Select this newly added column and click Design > Column Properties to open the properties box.

  8. On the first tab, type "Categories" in the Title field.
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  9. On the last tab, at the bottom, select Category Property for the Composite Settings Property value.

 10. Click File > Save to save your changes to this view.

 11. To see your changes, click Design > Preview in Notes.
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Result: The view appears in Lotus Notes 8 Beta. You will see the newly added column that lists the
categories values for the documents you created in Lesson 1.  

Note  You may need to scroll to the right in the view to see this newly added column.

Congratulations. You have completed Lesson 5. You have added a property to your Notes application.
Later when this Notes view is used as a component in a composite application, you will see how this
property can be wired to the action of another component to support inter-component interaction through
Lotus Notes 8 Beta property broker functionality.

Please proceed to Lesson 5.
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Lesson 5 -- Defining Notes actions that consume properties  

Welcome to Lesson 5.

In the previous lessons, you completed the following procedures:

 Create a local Notes database using the discussion template.

 Create documents in that database.

 Add a new Notes form to the Notes database.

 Generate a WSDL file that lists the properties and actions for a Notes component.

 Import the WSDL f ile into your application that will be used as a Notes component.

 Add a new view column that, when selected, will publish a property that can be used in a
composite application.

In this lesson, you will add an action to a Notes form. This action will consume the property published by
another component in your composite application that you assemble and wire in a later lesson.

See the toolkit documentation topic "Building Notes components" for more information about the new
LotusScript classes, methods and properties.

Note  To complete this tutorial, you need Lotus Notes 8 Beta and Lotus Domino Designer 8 Beta software
installed and set up.

Lesson 5 objective 

In this lesson you will use one procedure to accomplish the following tasks::

 Add a new action to the DocByCategory form.

 Input LotusScript code to specify what the new action does.
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Lesson 5 procedure  

Complete the following steps to add the action to your Notes form.

  1. If Domino Designer 8 Beta is not already running, start it now and open MyDiscussion.nsf.  

Note  If there is no bookmark for MyDiscussion.nsf already displayed in Domino Designer 8 Beta,
click File > Application > Open then select MyDiscussion.

  2. If needed, switch to the Forms list by clicking Forms in the designer pane on the left.

  3. Click the DocByCategoryForm form and press Enter to open it in design mode. Your screen should
look similar to the following graphic.  

Note  You created this form in Lesson 2.

  4. Click Create > Action > Action... to add a new action to this form.

Result: The action pane opens in the right top and the properties box appears for the new action.

  5. On the first tab of the properties box, type "TutorialAction1" in the Name field.

  6. On the last tab of the properties box, click CategoryAction in the Composite Settings Action Name
field list at the bottom. 
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  7. Close the properties box.

  8. Click the newly created action TutorialAction1 in the action pane on the top right.

  9. In the programmers pane at the bottom right, click the Client and LotusScript settings for the Run
field.

 10. Input the following LotusScript code in the Click subroutine.  

Note  The action script will create an object of the new NotesPropertyBroker class and use the
property published by the other component to update the CategorytoDisplay field and refresh the
front-end document.  As the embedded view is set to display a single category, it will then list
documents in that single category.

Note  Bold comment text is used to describe various code lines.

Tip  You can copy and paste the following. If needed, after pasting the code, remove any duplicate
Sub and End Sub statements. Bold text is comment annotation.
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Sub Click(Source As Button)

Dim s As New Notessession

Dim db As NotesDatabase

Set db = s.currentdatabase  'handle to the database 

'where this form is located.

Dim ws As New NotesUIWorkspace

Dim uidb As NotesUIDatabase

Dim uidoc As NotesUIDocument

'handle error 4719, returned when the script is run 

'without a property broker context

On Error 4719 Goto err4719

'new property broker code

Dim pb As NotesPropertyBroker

Set pb = s.getPropertyBroker("com.ibm.apps.sample") 'create 

'new NotesPropertyBroker object

'com.ibm.apps.sample -- this is the namespace used in the WSDL

Dim pbInputProperty As NotesProperty

Dim pbcontext As Variant

pbContext = pb.InputPropertyContext 'array of NotesProperty objects

Set pbInputProperty = pbContext(0) 'handle to first 

'NotesProperty object

Dim InputPropertyName As String

Dim Namespace As String

InputPropertyName = pbInputProperty.Name 'name of the 

'NotesProperty object

NameSpace = pbInputProperty.NameSpace     'namespace of the

'NotesProperty object

'Print "InputPropertyName = " & InputPropertyName 

'&" NameSpace = " & NameSpace

Dim pbvalue As Variant

pbValue = pb.GetPropertyValue(InputPropertyName, NameSpace) 

'array of values of NotesProperty

cName$ = pbValue(0) 'first value from array 

'of values of NotesProperty object

SkipPropertyBroker:

If cName$ = "" Then

cName$ = Inputbox("Filter", cName$)

If cname$ = "" Then

Exit Sub

End If

End If
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' Messagebox cName$

Set UIdoc = ws.CurrentDocument  'handle to onscreen document

Call uidoc.FieldSetText("CategorytoDisplay",cName$)

Call uidoc.Refresh

Exit Sub

err4719:

Print "Error" & Str(Err) & ": " &Error$

Messagebox "error"

Resume skipPropertyBroker

End Sub

 11. Click File > Save to save your form changes.

 12. Click File > Close to exit design mode.

Congratulations. You have completed Lesson 5. You have added an action to the Notes form. When you
later use this Notes form as a component in a composite application, the component can consume a
published property and perform the action defined by the LotusScript code.

Please proceed to Lesson 7.
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Lesson 6 -- Creating a composite application  

Welcome to Lesson 6.

In the previous lessons, you completed the following procedures:

 Create a local Notes database using the discussion template.

 Create documents in that database.

 Add a new Notes form to the Notes database.

 Generate a WSDL file that lists the properties and actions for a Notes component.

 Import the WSDL f ile into your application that will be used as a Notes component.

 Add a new view column that, when selected, will publish a property that can be used in a
composite application.

 Add a new form action that will perform an activity when the property is published.

In this lesson, you will create a new that will be a composite application for use in Lotus Notes 8 Beta.

Note  To complete this tutorial, you need Lotus Notes 8 Beta and Lotus Domino Designer 8 Beta software
installed and set up.

Lesson 6 objective 
In this lesson you will use one procedure to accomplish the following task:

 Create a new composite application stored in a Notes database.
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Lesson 6 procedure  

Complete the following steps to add the action to create a new composite application stored in a Notes
database.

  1. If Lotus Notes 8 Beta is not already running, start it now.

  2. Click File > Application > New.

Result: The New Database dialog appears.

  3. Leave the Server field value set to Local.

  4. Type "MyCompApp" in the Title field.

  5. Type "MyCompApp.nsf" in the File Name field.

  6. Select –Blank Composite Application- in the Template field.

  7. Click OK to close the dialog box and create the new database.

Result: The new database is created and a blank application, similar to the graphic excerpt below,
appears in your Lotus Notes 8 Beta client.
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  8. Open Domino Designer 8 Beta, click  File > Application > Open and select MyCompApp.nsf from
the list of available options.

  9. In Domino Designer 8 Beta, click File > Application > Properties.

 10. Click the Launch tab. This is the fifth tab.

 11. Ensure that the When opened in the Notes client field is set to Launch as Composite
Application.
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 12. Close the properties box and close Domino Designer 8 Beta.

Congratulations. You have completed Lesson 6. You have created a composite application. In the following
lessons, you will use the Composite Applications Editor feature to add components to this composite
application and wire the properties and actions of the components to define the inter-component
communication.

Please proceed to Lesson 7.
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Lesson 7 -- Adding components to the composite application  

Welcome to Lesson 7.

In the previous lessons, you completed the following procedures:

 Create a local Notes database using the discussion template.

 Create documents in that database.

 Add a new Notes form to the Notes database.

 Generate a WSDL file that lists the properties and actions for a Notes component.

 Import the WSDL f ile into your application that will be used as a Notes component.

 Add a new view column that, when selected, will publish a property that can be used in a
composite application.

 Add a new action to a form, that will perform activity when the a property is published.

 Create a database and set the database properties to launch as a composite application for
Notes clients.

In this lesson you will use the Composite Application Editor feature to assemble the Notes components, that
you developed earlier into a two component composite application.

Note  You must be using an online location to successfully complete this lesson.

Note  To complete this tutorial, you need Lotus Notes 8 Beta and Lotus Domino Designer 8 Beta software
installed and set up.

Lesson 7 objective  

In this lesson you will use three procedures to add and wire components in the Composite Applications
Editor. You will perform the following tasks:

 Launch the Composite Application Editor.

 Add components to the Composite Application Editor component palette.

 Define visual placement of components on a composite application page using drag and drop.

36



Lesson 7 procedure  

Perform the following three procedures to accomplish the lesson objectives.

Launch the Composite Application Editor
Complete the following steps to open the Composite Application Editor feature.

  1. If Lotus Notes 8 Beta is not already running, start it now. 

  2. Click File > Open > Lotus Notes Application to open the MyCompApp composite application you
created in Lesson 7.

Result: The Open Application dialog appears.

  3. Click MyCompApp in the dialog.

Result: A new empty page entitled Blank Page appears.

  4. Click Actions > Edit Application.

Result: The Composite Application Editor, as seen in the following graphic excerpt, appears in a new
window.

  5. Select and right-click on the page labeled Blank Page on the Navigator on the left and select
Rename... from the resultant menu.

  6. Change the name to MyCompApp and press Enter to accept the new page name.  
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Add components using the Composite Application Editor component palette
Complete the following steps to add components to the component palette of the Composite Application
Editor feature.

  1. Expand the Component Palette on the right and click the push pin icon on the right to pin open the
display.

  2. Place your mouse below the General folder, then right-click and select Add Components > Add
Domino Components as shown in the graphic below.
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Result: The New NSF Component dialog appears.

  3. In the New NSF Component dialog, type the following values:

a.Type "My Discussion - All Documents" in the Component Name field.
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b.Type "My Discussion - All Documents" in the Component Description field.

c.Type "notes:///MyDiscussion.nsf?OpenDatabase" in the Notes URL field.

d.Type "General" in the Category field.

Your result should match the following graphic:

Note  You can also use the Browse button to generate the Notes URL.

The browse button will generate a Notes URL with the Replica ID and Alias view name. 
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In either case the URL points to the Lotus Notes 8 Beta component you created earlier in the tutorial.

  4. Click OK to accept these values.

Result: A progress indicator appears with the message "Provisioning components ...".  The newly
added component then appears in the Component Palette on the right as shown in the following
graphic.
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  5. To add a second component, again expand the Component Palette on the right, right-click under
the General folder, and click Add Components > Add Domino Components.

Result: The New Domino Component dialog appears.

  6. For your second component, type the following values:

a.Type "My Discussion - Category Form" in the Component Name field.

b.Type "My Discussion - Category Form" in the Component Description field.

c.Type "notes:///MyDiscussion.nsf/DocByCategoryForm?OpenForm" in the Notes URL field.

Note  You can also use the Templates button to view the general syntax.

Note  The Notes URL field points to the Lotus Notes 8 Beta component that you created earlier in
the tutorial.

a.Type "General" in the Category field.

Your result should match the following graphic:
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  7. Click OK to accept these values.

Result: A progress indicator appears with the message "Provisioning components ....".  The newly
added component then appears in the Component Palette on the right as shown in the following
graphic.
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Note  Your components are listed in the General category of the Component Palette.  You may
wish to add new categories to your Component Palette and organize your components by these
categories. See the Composite Application Editor documentation topic labeled, "Managing the
components on the component palette'" for more information.

Define visual placement of components on a composite application page using drag and
drop
Complete these steps to define visual placement of components on the composite application page by
using drag and drop.

  1. In the General folder area, select My Discussion - All Document and drag the component from the
component palette on the right to the Blank Application area in the center.

An example of a successfully placed component is shown below:

  2. Repeat the previous step to place the My Discussion - Category Form component. Drag the
component from the Component Palette on the right to the bottom half area in the center. 
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  3. Click Editing > Close to save your changes and close the Composite Application Editor.

  4. When prompted, click Yes to save your work.

Result:  The Composite Application Editor closes and the components appear in your Lotus Notes 8
Beta composite application.
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Congratulations. You have completed Lesson 7. You have assembled a composite application. In the next
lesson, you will wire the application to allow one component to consume the property published by another
component.

Please proceed to Lesson 8.
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Lesson 8 -- Wiring components in the composite application  

Welcome to Lesson 8.

In the previous lessons, you completed the following procedures:

 Create a local Notes database using the discussion template.

 Create documents in that database.

 Add a new Notes form to the Notes database.

 Generate a WSDL file that lists the properties and actions for a Notes component.

 Import the WSDL f ile into your application that will be used as a Notes component.

 Add a new view column that, when selected, will publish a property that can be used in a
composite application.

 Add a new action to a form, that will perform activity when the a property is published.

 Creat a database and set the database properties to launch as a composite application for Notes
clients.

 Add two Notes components to your composite application using the Composite Application
Editor.

In this lesson you will wire your components together in a causal relationship.

Note  You must be using an online location to successfully complete this lesson.

Note  To complete this tutorial, you need Lotus Notes 8 Beta and Lotus Domino Designer 8 Beta software
installed and set up.

Lesson 8 objective  

In this lesson you will use one procedure to accomplish the following task:

 Wire your components together in a causal relationship.
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Lesson 8 procedure  

Complete the following steps to wire your components in a causal relationship.

  1. If Lotus Notes 8 Beta is not already running, start it now.

  2. Click File > Open > Lotus Notes Application to open the MyCompApp composite application you
modified in Lesson 8.

Result:  The Open Application dialog appears.

  3. Click MyCompApp in the dialog.

Result:  The composite application appears and displays two components.

  4. Click Actions > Edit Application to start Composite Application Editor.

  5. Click My Discussion - All Documents in the navigator, then right-click and select Wiring.

Result:  The Composite Applications Editor wiring interface appears, as shown below.
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  6. Select the single  property listed in My Discussion - All Documents property, which is the
component labeled Source.

  7. Hold your left mouse button and drag to the single action listed in the My Discussion - Category
Form component. 

Note  A blue arrow appears as you drag from the property to the action.

  8. Release the mouse button.

Result:  A dotted line appears to indicate the wiring between property and action.

  9. Click OK to close the wiring interface.

 10. Click  Editing > Close.
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Result:  This closes the Composite Application Editor and displays the Lotus Notes 8 Beta user
interface.

 11. Close the composite application and then reopen it by clicking Application > Open > Lotus Notes
Application.

Note  You can see the result of your wiring by selecting a document in view in the upper composite.
Whenever you select a row that displays a different category than that previously selected, the
embedded view in the bottom component changes. It may not be visually apparent, but the property
is published from the upper component with each row selection you perform.

Congratulations. You have completed Lesson 9. You have finished all the lessons and have used your
Notes application development skills and new features and functions in Lotus Notes 8 Beta and Domino
Designer 8 Beta to create a composite application with inter-component communication using property
broker functionality.

Congratulations on completing this tutorial. For related information about composite applications in Lotus
Notes 8 Beta, see the composite applications toolkit documentation, the references mentioned in the last
topic of that document, and the Beta release notes and product documentation.
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Further enhancing your composite application  
Now that the composite application is working and inter-component communication is apparent, you may
wish to refine the appearance of your composite application and make it available to other Lotus Notes 8
Beta users.

Explore the new features and functions provided to improve the composite application you created.

Possible enhancements you might make include the following:

 Use the Composite Application Editor feature to remove the tabs at top of components so can
see more of each component

 Hide the Notes view column that publishes the property.

 Hide the CategorytoDisplay field on the Notes form you added in Lesson 2 to refine appearance
of the component.

 Hide the action bar button you added to the Notes form in Lesson 2.

Also try placing a copy or replica of MyDiscussion.nsf on your Domino 8 Beta server and create a
composite application on the Domino server using the Composite Application Editor feature.
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